Clover e-Commerce Issue

Incident Report for External Clover Status Page

Resolved

We've resolved the issue and all Clover systems are working as expected. Contact support if you have any concerns.
Posted Mar 06, 2025 - 13:46 PST

Investigating

Please be aware that Clover is experiencing an issue impacting e-commerce products, including Shopping cart plugins, Online Ordering, Virtual Terminal, and third-party e-commerce applications. Our engineering team is aware of the issue and is actively working to resolve it. We will provide further updates on the progress as soon as possible. We sincerely apologize for any inconvenience this may cause and appreciate your patience as we work to restore the service.
Posted Mar 06, 2025 - 13:26 PST
This incident affected: North America - Clover Services (E-Commerce, Online Ordering).