Rapid Deposit is Down
Incident Report for External Clover Status Page
Resolved
We've resolved the issue and all Clover systems are working as expected. Contact support if you have any concerns.
Posted Jan 25, 2025 - 14:10 PST
Update
We are aware that Rapid Deposit is not available at this time. We have engineers reviewing the issue and will advise on progress shortly. Please note that if Rapid Deposit remains unavailable, funds will be deposited according to your normal closeout schedule. Thank you for your ongoing patience.
Posted Jan 25, 2025 - 13:44 PST
Investigating
Clover monitoring alerted that Rapid Deposit success rates are down. Deposit attempts and eligibility checks are failing. Merchants will need to wait for their usual closeout schedule.
Posted Jan 25, 2025 - 13:32 PST
This incident affected: North America - Clover Services (Batch Closeouts, Closeouts).