Potential Service Disruption on Clover systems
Incident Report for External Clover Status Page
Resolved
Thank you again for your ongoing patience. We have cleared all the previously reported issues on the Clover platform and all services, including the Clover Dashboard, are functional. We apologize for the disruption earlier this evening and please reach out if you need any further support.
Posted Nov 10, 2023 - 01:12 PST
Update
Thank you again for your ongoing patience. Our engineers continue to actively work on remediating the remaining issues with our Clover devices along with restoring Clover dashboard access. We will send out another update shortly.
Posted Nov 09, 2023 - 20:13 PST
Identified
Thank you again for your ongoing patience. Our engineers are actively working on remediating any remaining issues with our Clover devices along with restoring Clover dashboard access. We will send another update in the next hour if not sooner.
Posted Nov 09, 2023 - 20:00 PST
Update
Clover API functionality has been restored. We are continuing to troubleshoot any remaining Clover dashboard or Clover device issues. Thank you for your ongoing patience and we will send another update within the hour.
Posted Nov 09, 2023 - 17:35 PST
Update
Update - Clover continues to troubleshoot the previously reported issues - engineering is actively engaged in remediating the issue. Thank you for your ongoing patience.
Posted Nov 09, 2023 - 16:24 PST
Investigating
We've identified an issue that may be impacting select Clover services and are actively working to resolve it. You may be unable to log in to some Clover services, including the Merchant Dashboard, eCommerce, APIs and third party applications. We'll send another update in 30 minutes
Posted Nov 09, 2023 - 15:29 PST
This incident affected: North America - Clover Services (North America - Payment Authorization Services, North America - Clover Platform Services).