[NA]Web dashboard login issues for a small subset of merchants on Safari Browsers

Incident Report for External Clover Status Page

Resolved

The issue has been resolved, and all Clover systems are working as expected. If you need further assistance, please contact Clover support at 1-877-273-8191. Thank you again for your patience while we worked through this issue.
Posted Sep 22, 2026 - 11:29 PDT

Investigating

We are currently investigating an issue where a small subset of merchants using the Safari browser are unable to log into the Web Dashboard or set up new accounts. Our engineering team is actively working on a fix to resolve this error. In the meantime, impacted users can bypass this issue by logging in or registering using an alternative web browser, such as Google Chrome, Mozilla Firefox, or Microsoft Edge. We appreciate your patience and will share another update as soon as more information becomes available.
Posted Sep 22, 2026 - 11:01 PDT
This incident affected: North America - Clover Services (Dashboard).