Clover is Experiencing an Issue

Incident Report for External Clover Status Page

Resolved

We've resolved the issue and all Clover systems are working as expected. Contact support if you have any concerns.
Posted Mar 29, 2023 - 10:08 PDT

Identified

We've identified an issue with our Customers and Online ordering app and are working to resolve it. We'll send another update in 30 minutes.
Posted Mar 29, 2023 - 08:34 PDT