Clover is Experiencing an Issue with Auto Batch Closeout
Incident Report for External Clover Status Page
Resolved
This incident has been resolved. Merchants will have their closeouts processed on their next available closeout window.
Posted Mar 17, 2023 - 03:59 PDT
Monitoring
Clover merchants may see a 24-Hrs delay on closeouts. The issue has since been mitigated and Merchants will have their closeouts processed on their next available closeout window.
Posted Mar 16, 2023 - 23:54 PDT