Clover is experiencing an issue with the Web Dashboard in the EU
Incident Report for External Clover Status Page
Resolved
We've resolved the issue and all Clover systems are working as expected. Contact support if you have any concerns.
Posted Sep 21, 2024 - 05:21 PDT
Investigating
Please note that Clover is experiencing intermittent latency on our Web Dashboard in the EU. We have our engineers engaged and will send another update shortly.
Posted Sep 21, 2024 - 04:52 PDT
This incident affected: European - Clover Services (Dashboard).