The issue has been resolved, and all Clover systems are working as expected. If you need further assistance, please contact Clover support at 1-877-273-8191. Thank you again for your patience while we worked through this issue.
Posted May 13, 2025 - 13:20 PDT
Update
We are continuing to work on a fix for this issue.
Posted May 13, 2025 - 10:26 PDT
Identified
We are continuing to investigate this issue.
Posted May 13, 2025 - 10:20 PDT
Investigating
We are currently investigating an issue where modifiers are appearing as "unavailable" on the Web Dashboard and merchant devices. As a result, employees may not see modifier options when placing orders. Merchants can manually restore affected modifiers by re-enabling them in the Inventory > Items section of the Dashboard or on device. We appreciate your patience and will provide updates as we work to resolve this issue.
Posted May 13, 2025 - 09:05 PDT
This incident affected: North America - Clover Services (Dashboard).