Clover is Experiencing DoorDash and UberEats Latency
Incident Report for External Clover Status Page
Resolved
We've resolved the issue and all Clover systems are working as expected. Contact support if you have any concerns.
Posted Aug 04, 2023 - 20:04 PDT
Monitoring
The fix has been applied and all systems are working normally. Please notify support if you are still having issues.
Posted Aug 04, 2023 - 19:39 PDT
Identified
We're experiencing latency with Uber Eats and DoorDash orders. We are investigating, and we'll send another update in 30 minutes.
Posted Aug 04, 2023 - 18:56 PDT