Clover is experiencing a batch funding delay

Incident Report for External Clover Status Page

Resolved

The issue has been resolved, and all Clover systems are working as expected. If you need further assistance, please contact Clover support at 1-877-273-8191. Thank you again for your patience while we worked through this issue.
Posted Nov 24, 2025 - 13:47 PST

Investigating

The issue affecting Clover systems has been resolved. However, please note the following impact on funding:
- Affected Batches: Late closeouts from Friday, November 21.
- New Deposit Date: Funds will be available on Monday, November 24 (instead of Saturday).
- Action Required: None. Please do not worry if you do not see Friday's funds yet; they are in the queue for Monday.
If you have questions outside of this specific delay, you may contact Clover Support at 1-877-273-8191.
Posted Nov 22, 2025 - 08:32 PST
This incident affected: North America - Clover Services (Batch Closeouts, Closeouts).