Clover Gift Card Issue
Incident Report for External Clover Status Page
Resolved
We've resolved the issue and all Clover systems are working as expected. Contact support if you have any concerns.
Posted Dec 20, 2023 - 15:04 PST
Investigating
Clover is aware of an issue where merchants are having issues redeeming and issuing gift cards. Engineering is investigating, and we will have another update shortly. Thank you for your patience.
Posted Dec 20, 2023 - 14:05 PST