Clover RapidDeposit may see intermittent delays. Funding will occur during normally scheduled windows.
Incident Report for External Clover Status Page
Resolved
This incident has been resolved.
Posted Jan 30, 2023 - 18:58 PST
Update
We are continuing to investigate this issue.
Posted Jan 30, 2023 - 18:57 PST
Investigating
Issue has been mitigated.
Posted Jan 30, 2023 - 18:46 PST
This incident affected: North America - Clover Services (North America - Clover Platform Services).