Clover is Experiencing an Issue with Some Kitchen Printers

Incident Report for External Clover Status Page

Resolved

The issue has been resolved, and all Clover systems are working as expected. If you need further assistance, please get in touch with Clover support at 1-877-273-8191. Thank you again for your patience while we worked through this issue.
Posted Jun 24, 2025 - 07:27 PDT

Monitoring

Clover engineers have identified the fix, and it will be distributed to the impacted merchants using the Star Kitchen printers tonight. We appreciate your continued patience.
Posted Jun 23, 2025 - 17:18 PDT

Identified

Clover engineering teams have identified the underlying issue and are working on a fix. Please note that this only impacts TSP100 (TSP143LAN) kitchen printers. We will post updates when they become available. Thank you for your patience.
Posted Jun 23, 2025 - 12:36 PDT

Investigating

We're currently investigating an issue affecting some Clover devices and their connection to Star Kitchen Printers. Our engineering teams are actively working on a resolution. We'll provide another update as soon as possible. Thank you for your patience.
Posted Jun 23, 2025 - 11:24 PDT
This incident affected: North America - Clover Services (Kitchen Printers).