Potential Service Disruption to Clover Devices Attempting to Process TeleCheck Transactions
Incident Report for External Clover Status Page
Resolved
We've resolved the issue and all Clover systems are working as expected. Contact support if you have any concerns.
Posted Feb 02, 2023 - 18:10 PST
Investigating
Fiserv has confirmed a disruption in service to Clover Devices attempting to process TeleCheck transactions. Impact is currently limited to a small subset of devices. Progress is being made to resolve the issue. Updates will continue to be provided as soon as possible.
Posted Feb 02, 2023 - 11:34 PST
This incident affected: North America - Clover Services (North America - Clover Platform Services).