Clover is experiencing latency issues with the Web Dashboard, Order synching, and device activation
Incident Report for External Clover Status Page
Resolved
We've resolved the issue, and all Clover systems are working as expected. Contact support if you have any concerns.
Posted Jun 04, 2024 - 12:40 PDT
Investigating
Please note that Clover merchants may be experiencing intermittent latency while trying to access the Clover web dashboard, order syncing across devices, and slowness while activating new Clover devices. Clover Engineering is currently working to resolve the issue. Thanks for your patience.
Posted Jun 04, 2024 - 10:48 PDT
This incident affected: North America - Clover Services (Dashboard).