Clover is experiencing issues with the Web Dashboard

Incident Report for External Clover Status Page

Resolved

We've resolved the issue, and all Clover systems are working as expected. Contact support if you have any concerns.
Posted Apr 22, 2025 - 00:15 PDT

Update

We are continuing to investigate this issue.
Posted Apr 21, 2025 - 23:15 PDT

Investigating

Please note that Clover merchants may be experiencing issues while accessing the Clover Web dashboard. Clover Engineering is currently working to resolve the issue. Thanks for your patience.
Posted Apr 21, 2025 - 23:14 PDT
This incident affected: North America - Clover Services (Dashboard).