Clover is Experiencing an Issue
Incident Report for External Clover Status Page
Resolved
We've resolved the issue and all Clover systems are working as expected. Contact support if you have any concerns.
Posted Apr 01, 2024 - 12:19 PDT
Monitoring
Fiserv is investigating a potential service disruption to Clover and Commerce Hub. The impact is limited to clients who have migrated from the Payeezy Gateway to Commerce Hub or Clover. Further updates will be provided as soon as possible.
Posted Apr 01, 2024 - 11:55 PDT
This incident affected: North America - Clover Services (E-Commerce).