The impacted services are actively recovering; we will continue to monitor until full health is restored. If you need further assistance, please contact Clover support. Thank you again for your patience while we worked through this issue.
Posted Sep 16, 2026 - 08:50 PDT
Identified
We have identified the issue. We are actively working to remediate this issue. We appreciate the patience.
Posted Sep 16, 2026 - 07:57 PDT
Update
Clover merchants may currently experiencing issues with Web Dashboard login and Syncing between devices, Cloud Pay Display Payments, Refunds and Voids. Our engineers are actively working to fix the issue. We greatly appreciate your ongoing patience as we work to resolve this issue, and we will provide an update once we have an estimated time for resolution. Thank you for your understanding.
Posted Sep 16, 2026 - 06:17 PDT
Investigating
Clover merchants may currently experience issues with Cloud Pay Display functionality and Merchant Web Dashboards. Our engineers are actively working on identifying the root cause. We greatly appreciate your ongoing patience as we work to resolve this issue, and we will provide an update once we have an estimated time for resolution. Thank you for your understanding.
Posted Sep 16, 2026 - 05:31 PDT
This incident affected: Europe - Clover Services (Dashboard, Cloud Pay Display).