Partial disruption to services; Clover Customer Applications such as Promos, Awards, and Invoices may see an interruption to service

Incident Report for External Clover Status Page

Resolved

This incident has been resolved.
Posted Nov 11, 2022 - 09:08 PST

Investigating

We are currently investigating this issue.
Posted Nov 11, 2022 - 08:56 PST
This incident affected: North America - Clover Services (North America - Clover Platform Services, Dashboard).