Elevated payment transaction errors
Incident Report for External Clover Status Page
Resolved
This incident has been resolved.
Posted Mar 02, 2020 - 18:26 PST
Monitoring
We're experiencing an elevated level of payment transaction errors. The issue has been identified and a fix has been implemented. We are currently monitoring our results for any further issues.
Posted Mar 02, 2020 - 17:00 PST