The issue has been resolved, and all Clover systems are working as expected. If you need further assistance, please contact Clover support at 1-877-273-8191. Thank you again for your patience while we worked through this issue.
Posted Nov 06, 2025 - 00:03 PST
Identified
We have identified the issue. We are actively working to remediate this issue and will send another update shortly.
Posted Nov 05, 2025 - 23:16 PST
Update
Clover merchants might be experiencing issues with multiple Clover services, including the Merchant Dashboard, eCommerce, APIs, Clover Web Dashboard, Virtual Terminal, managing Online Orders, Clover GO, and Cloud Pay Display, and third-party applications. The Clover Engineering team is currently working on resolving this issue. We appreciate your patience.
Posted Nov 05, 2025 - 22:32 PST
Investigating
We've identified an issue that may be impacting multiple Clover services and are actively working to resolve it. You may be unable to log in to some Clover services, inclu/ding the Merchant Dashboard, eCommerce, APIs, and third-party applications. We'll send another update in 30 minutes
Posted Nov 05, 2025 - 22:07 PST
This incident affected: North America - Clover Services (North America - Payment Authorization Services, North America - Clover Platform Services, Clover GO, Dashboard, Clover Sport, Tips, Refunds, Payments, Batch Closeouts, Closeouts, Card Issuer Processing, E-Commerce, Online Ordering, Cloud Pay Display, Invoicing, Online Booking, Online Shopping, Website Builder, Appointment Booking, Call Centers, Multi-Factor Authentication, Kitchen Printers).