Ecomm: Merchants are unable to create or view invoices on Virtual Terminal
Incident Report for External Clover Status Page
Resolved
This incident has been resolved.
Posted Feb 21, 2023 - 09:02 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 21, 2023 - 08:32 PST
This incident affected: North America - Clover Services (North America - Clover Platform Services).