The issue has been resolved, and all Clover systems are working as expected. If you need further assistance, please contact Clover support at 1-877-273-8191. Thank you again for your patience while we worked through this issue.
Posted Aug 30, 2026 - 00:44 PDT
Update
We are investigating an issue affecting payment processing for some merchants. Our engineering teams are actively working on a fix. We will provide updates here as soon as more information is available. Thank you for your patience.
Posted Aug 29, 2026 - 23:17 PDT
Investigating
We are investigating an issue affecting payment processing for some merchants. Our engineering teams are actively working on a fix. We will provide updates here as soon as more information is available. Thank you for your patience.
Posted Aug 29, 2026 - 22:49 PDT
This incident affected: North America - Clover Services (North America - Payment Authorization Services).