Clover is experiencing an Issue with the Merchant Dashboard
Incident Report for External Clover Status Page
Resolved
We've resolved the issue and all Clover systems are working as expected. Contact support if you have any concerns.
Posted Nov 01, 2023 - 14:31 PDT
Update
The Clover team continues to troubleshoot the reported issues. Merchants may still see issues logging in to the Merchant Dashboard and may see intermittent issues with other services such as Virtual Terminal, Reports, Orders, Clover APIs, and Refunds.
Posted Nov 01, 2023 - 12:26 PDT
Update
Clover Engineering is continuing to work on a change to remediate the reported interruption. Merchants may still see issues logging in to the Merchant Dashboard and may see intermittent issues with other services such as Virtual Terminal, Reports, Order, Clover APIs, and Refunds.
Posted Nov 01, 2023 - 10:30 PDT
Update
Thank you for your ongoing patience as we continue to investigate the intermittent issues on Clover dashboard and other Clover services. We've identified a possible fix and are working to remediate the issue quickly. Clover devices and payments are working as expected. We'll send another update in 30 minutes.
Posted Nov 01, 2023 - 09:30 PDT
Update
We are continuing to work on a fix for this issue.
Posted Nov 01, 2023 - 08:49 PDT
Identified
We've identified a possible issue that may be impacting select Clover services and are actively working to resolve it. You may be unable to log in to some Clover services, including the Merchant Dashboard, eCommerce, and third party applications. Clover devices are working as expected. We'll send another update in 30 minutes.
Posted Nov 01, 2023 - 08:49 PDT
This incident affected: North America - Clover Services (Dashboard).