Clover Support service center is not able to accept inbound phone calls at this time
Incident Report for External Clover Status Page
Resolved
Clover Support service center can take calls. The issue was resolved, and all is good now.
Posted Oct 17, 2024 - 06:47 PDT
Investigating
Please note that our Clover Support service center is not able to accept inbound phone calls at this time. Please refer to https://www.clover.com/en-US/help for any troubleshooting needs. We will keep you posted as we work to resolve this service disruption. Thank you for your patience.
Posted Oct 17, 2024 - 05:53 PDT