High Latencies for Clover Go
Incident Report for External Clover Status Page
Resolved
This incident has been resolved.
Posted Jul 20, 2020 - 00:00 PDT
Update
As of 9 PM ET on July 14th, 2020, latency for Clover Go transactions has been in the normal range. We will continue monitoring until July 20th, 2020.
Posted Jul 16, 2020 - 12:58 PDT
Monitoring
On July 14th, 2020, Clover Go transactions were experiencing higher latency. We've implemented mitigation steps, and since 9 PM ET on July 14th, 2020, we are seeing normal latency with Clover Go transactions.
Posted Jul 15, 2020 - 13:06 PDT
This incident affected: Developer Services (Clover Platform API, Dashboard, Webhooks, Cloud Pay Display).