Partial, disruption to on-line ordering services
Incident Report for External Clover Status Page
Resolved
This incident has been resolved.
Posted Jul 30, 2023 - 12:59 PDT
Investigating
Clover merchants may see intermittent disruption when using Clover On-Line Ordering and/or third-party integrations. Engineering is currently investigating
Posted Jul 30, 2023 - 10:59 PDT
This incident affected: North America - Clover Services (North America - Clover Platform Services).