Clover Go Experiencing Increased Latency
Incident Report for External Clover Status Page
Resolved
This incident has been resolved.
Posted Jul 31, 2020 - 16:10 PDT
Investigating
Clover Go is currently in limited mode. There is no impact to SDK transactions. Other functions may be impacted.
Posted Jul 31, 2020 - 12:55 PDT