Clover is experiencing an issue with EU Payments

Incident Report for External Clover Status Page

Resolved

We've resolved the issue and all Clover systems are working as expected. Contact support if you have any concerns.
Posted Sep 12, 2024 - 06:51 PDT

Update

We continue investigating this issue and appreciate your patience.
Posted Sep 12, 2024 - 06:11 PDT

Update

We continue investigating this issue and appreciate your patience.
Posted Sep 12, 2024 - 04:27 PDT

Update

We are continuing to investigate this issue.
Posted Sep 12, 2024 - 02:55 PDT

Investigating

Clover Merchants are experiencing system issues that have failed payment processing and authorizations. As a result, payments cannot be made or authorized at this time. The engineering team is aware of the situation and is working diligently to resolve the issue. In the meantime, we apologize for any inconvenience this may cause and appreciate your patience. We will provide updates as soon as the technical issues have been resolved.
Posted Sep 12, 2024 - 02:07 PDT
This incident affected: European - Clover Services (European - Auth Services, European - COS Services, Dashboard).