We've resolved the issue and all Clover systems are working as expected. Contact support if you have any concerns.
Posted Aug 28, 2024 - 09:04 PDT
Update
Clover Engineering has partially fixed the issue affecting invoice creation and payment, as well as the ability to send payment links on Clover. Our engineering team has made progress in resolving the issue and is actively working on fully restoring all functionalities as soon as possible. Our next update will be at 7:00 AM EST or sooner if this issue is fully mitigated. We appreciate your patience and ongoing support.
Posted Aug 27, 2024 - 20:27 PDT
Update
We are still investigating the issue impacting invoice creation and payment and the ability to send payment links on Clover. Our engineering team is working on resolving this matter and restoring all functionalities as soon as possible. We appreciate your patience and ongoing support.
Posted Aug 27, 2024 - 14:49 PDT
Update
We continue to investigate this issue and appreciate your ongoing patience.
Posted Aug 27, 2024 - 12:23 PDT
Investigating
We are currently experiencing an issue that is impacting Clover's invoicing functionality. You may be unable to view existing invoices or create new ones at this time. We greatly appreciate your ongoing patience as we work to resolve this issue and will provide an update once we have an estimated time for resolution
Posted Aug 27, 2024 - 11:16 PDT
This incident affected: North America - Clover Services (Invoicing).