Clover is Experiencing an Issue with Some Mini2 Devices
Incident Report for External Clover Status Page
Resolved
We've resolved the issue and all Clover systems are working as expected. Contact support if you have any concerns.
Posted Jun 28, 2023 - 11:29 PDT
Monitoring
If you are experiencing errors processing manual cards on your Clover Mini 2, please reboot your Clover point of sale system now to receive the latest update. This update should resolve your error.
Posted Jun 28, 2023 - 11:06 PDT
Update
Some merchants are unable to enter card numbers manually on their Mini 2 to process payments. Clover Engineering is investigating a solution.
Posted Jun 28, 2023 - 10:27 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 28, 2023 - 09:34 PDT
Investigating
Clover is experiencing some intermittent issues at this time. There is no action you need to take - we will post another update here within the next 30 minutes.
Posted Jun 28, 2023 - 09:17 PDT