Mastercard Card Processing Issue

Incident Report for External Clover Status Page

Resolved

Mastercard has resolved its issue, and all Clover systems are working as expected. Please contact support if you have any concerns.
Posted Mar 09, 2025 - 04:12 PDT

Investigating

We are aware that Mastercard is experiencing a nationwide outage that may impact processing for some merchants. Our teams are working closely with Mastercard to resolve the issue as quickly as possible.
Please note that this is an issue affecting Mastercard's systems and not a Clover-specific problem. We will continue to monitor the situation and provide updates as more information becomes available.
Thank you for your patience and understanding.
Posted Mar 09, 2025 - 03:14 PDT
This incident affected: North America - Clover Services (Card Issuer Processing).