Clover is Experiencing an Issue with Online Ordering
Incident Report for External Clover Status Page
Resolved
We've resolved the issue with Clover Online Ordering, and all Clover systems are working as expected. Contact support if you have any concerns.
Posted Jan 30, 2025 - 17:54 PST
Investigating
We are aware that Clover Online Ordering is currently unavailable. Our engineering team is actively reviewing the issue and will provide an update on progress shortly. We apologize for the inconvenience and appreciate your patience.
Posted Jan 30, 2025 - 16:28 PST
This incident affected: North America - Clover Services (Online Ordering).