We've resolved the issue, and all Clover systems are working as expected. Contact support if you have any concerns. Thank you again for your patience while we worked through this issue.
Posted Mar 18, 2025 - 21:56 PDT
Monitoring
Services in the EU are gradually returning to normal. Merchant Dashboards and new orders are now processing as expected. Clover engineers are actively working to fully resolve the issue. Thank you for your continued patience.
Posted Mar 18, 2025 - 15:11 PDT
Identified
Clover merchants in the EU: We are experiencing a service disruption that will impact tips, refunds, and adjustments. Merchants can take payments but might not see the transaction immediately on their devices. Clover Engineers are actively working to resolve the issue as quickly as possible.
Posted Mar 18, 2025 - 13:18 PDT
Investigating
Clover merchants in the EU are experiencing a service disruption that will impact tips, refunds, and adjustments. Merchants can take payments but might not see the transaction immediately on their devices. Clover Engineers are actively working to resolve the issue as quickly as possible.
Posted Mar 18, 2025 - 11:42 PDT
This incident affected: European - Clover Services (European - COS Services).