Clover is experiencing an Issue with the web dashboard
Incident Report for External Clover Status Page
Resolved
Thank you again for your patience today. We have resolved all issues, and our systems are working as expected. We appreciate your business and apologize again for these issues.
Posted Feb 21, 2024 - 19:32 PST
Update
Thank you again for your ongoing patience as we continue to resolve the Clover dashboard latency you may be experiencing today. As we mentioned earlier, there may also be intermittent online ordering and app connectivity issues via our Cloud Pay display integration. We have our full engineering team engaged to get this resolved as soon as possible.
Posted Feb 21, 2024 - 12:10 PST
Update
We are continuing to work on a fix for this issue.
Posted Feb 21, 2024 - 09:00 PST
Update
Clover’s engineering team continues to fully resolve the Clover dashboard latency you may be experiencing. There may also be intermittent online ordering and app connectivity issues via our Cloud Pay display integration. Thanks for your ongoing patience.
Posted Feb 21, 2024 - 08:52 PST
Update
Thank you for your ongoing patience while we work to resolve the intermittent latency on Clover’s Web Dashboard. Our engineers are actively working to restore all functionality and will send another update shortly.
Posted Feb 21, 2024 - 06:11 PST
Update
We are continuing to work on a fix for this issue.
Posted Feb 21, 2024 - 04:14 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 21, 2024 - 04:10 PST
Investigating
Please note that Clover is experiencing intermittent latency on our Web Dashboard. We have our engineers engaged and will send another update shortly.
Posted Feb 21, 2024 - 04:09 PST
This incident affected: North America - Clover Services (Dashboard, Online Ordering).