Clover Call Center Phone Issue
Incident Report for External Clover Status Page
Resolved
We've resolved the issue, and Clover support calls are going through as expected. Contact support if you have any concerns.
Posted Jan 16, 2025 - 17:08 PST
Investigating
Please note that our phone systems are experiencing issues that may cause delays when contacting Clover Support. Our engineering teams are actively working to resolve the issue as quickly as possible. We appreciate your understanding and patience during this time.
Posted Jan 16, 2025 - 15:18 PST