Clover is experiencing an issue with Clover Online Ordering
Incident Report for External Clover Status Page
Resolved
We've resolved the issue, and all Clover Online Ordering is working as expected. Contact support if you have any concerns.
Posted Feb 04, 2025 - 12:02 PST
Investigating
We are aware that Clover Online Ordering is intermittently unavailable. Our engineering team is actively reviewing the issue and will provide an update on progress shortly. We apologize for the inconvenience and appreciate your patience.
Posted Feb 04, 2025 - 11:21 PST
This incident affected: North America - Clover Services (Online Ordering).